TWBlue TWBlew Up, But It’s Fixable

I’m not much for Twitter anymore, but I still keep a client on my phone and my desktop for the times I do feel like playing with it, in case someone talks to me there and to keep tabs on what a few people are up to. One of those clients is TWBlue, obviously.

A couple of days ago, the thing absolutely flipped its shit. A few days before then, something would pop up occasionally saying that someone had blocked me and that it was going to remove that person’s tweets from my timelines. I would press ok and go on my way, after spending a couple of seconds wondering who the rat bastard was and what he thought I did, of course. Later that day, I happened to see another person tweeting about the same thing happening to her. I started to realize that this was likely some sort of error and not legitimate blocks since neither of us had ever seen it before and now we were getting it repeatedly on the same day. I put it out of my mind after that, but then Wednesday’s aforementioned shit flipping occurred.

I saw the block message, hit the ok button, and then promttly saw it again. And again. And again. And again. And again. And…ok, let’s hit this bad boy with the task manager, because it ain’t stoppin’.

With that taken care of, I got on with life and gave it no more thought. It only came back to mind when I had to reboot the system to install some updates. That’s when I noticed hey, TWBlue didn’t run like it’s supposed to. That’s odd. I tried starting it a couple of times, but nothing would happen. I eventually deleted its folder in AppData and tried again. It ran, but only to a point. I got as far as the we’re going to take you to a website to start the account authorization process, but no further. I wasn’t taken to a website. It just sat there in the new account dialogue, waiting for one of us to blink. I guess I blinked first, because I wound up closing and uninstalling it.

Which brings me to today.

One of Carin’s Facebook friends posted something asking what in hell was wrong with it. This was the first Carin had heard of any problems, so she asked if I knew anything. All I could say was “oh, so it’s not just me then?” That brought me to Google, which brought me here.

Long story short, a series of development decisions and other circumstances have meant big changes to the software. Big enough that it can’t gracefully update itself. You can go here to get the new one.

Remember to uninstall the old one before you try doing anything with it, though. If you’re anything like the other person I’ve helped along with this, installing over top isn’t going to work. In fact, if you’re like me, even after installing the new one you may have to run %appdata% and delete the folder again. When I first installed and tried to run it, it just sat there doing nothing like the old one did. But after deleting that folder and trying again, things are humming along as good as they ever did. I had to authorize my account again, but that only takes a few seconds when the website that’s supposed to open actually does.

Now that you’ve gotten that fixed, why not use your new powers to give Carin and I a follow? I don’t say much and she says even less, but you’ll get links to all of the new posts and sporadic bits of other stupidity, so it may or may not be worth your time.

Leave a comment

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.